git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: What's cooking in git.git (Jan 2016, #02; Mon, 11)

From
Junio C Hamano <gitster@pobox.com>
Date
Jan 13, 2016, 23:07 UTC
Message-ID
<xmqqtwmhkrj2.fsf@gitster.mtv.corp.google.com>
In-Reply-To
<20160112214909.GD2841@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 19 quoted lines
> On Tue, Jan 12, 2016 at 10:47:25AM -0800, Junio C Hamano wrote:
>
>> I think strbuf_getline() that handles the payload as "text" without
>> having _crlf() suffix is an ideal endgame in the longer term, but I
>> do not think it is a good idea to do that as a flag-day change.  So
>> I am inclined not to change the function names around that feature
>> in this series.  Others can do the wholesale rename as a separate
>> follow-up topic when the tree is quiescent.
>
> Yeah, I think we would want to catch topics in flight. Should the end of
> this series then be to _remove_ strbuf_getline()? Callers should be
> using strbuf_getline_crlf() if they want text lines, and
> strbuf_getdelim() if they do not.
>
> Topics in flight will need fixed up, but that's OK; the breakage (and
> the fix) will be obvious.
>
> And then after a quiet period we can drop the "_crlf()" and have
> strbuf_getline() back.
Actually, I think a patch that
 - renames strbuf_getline() to strbuf_getdelim(); and
 - renames strbuf_getline_crlf() to strbuf_getline() 

on top of the series we already have is sufficient to bring the endgame state to us. The new strbuf_getline() has a different function signature from the traditional one, so any topic in flight that is unaware of this series can easily be caught, and we can do this without a quiet period.

A more interesting question is if strbuf_getdelim() should take an arbitrary byte as its third parameter. As I said elsewhere, the only reason why it is not a "do we use LF or do we use NUL?" boolean is because I wrote these codepaths anticipating that there might be a value other than NUL and LF that could be useful when I introduced line_termination long time ago, but no useful caller that uses other useful value has emerged, so I think the interface was too broad and too general for its own good.

It becomes very tempting not to do strbuf_getdelim() at all, but instead rewrite the current calls to strbuf_getline() to call one of two functions, i.e. strbuf_getline_lf() and strbuf_getline_nul(), when we rename strbuf_getline_crlf() to strbuf_getline().

By going that route, those who want to help CRLF situation further can then concentrate on output from "git grep strbuf_getline_lf()", identify the ones that can be safely turned into strbuf_getline(), and do the conversion.

Previous: Jeff KingNext: Jeff King
Message 8 of 19 in “What's cooking in git.git (Jan 2016, #02; Mon, 11)”
  1. Junio C HamanoJan 11, 2016
  2. Mike HommeyJan 12, 2016
  3. Junio C HamanoJan 12, 2016
  4. Edmundo Carmona AntoranzJan 12, 2016
  5. Johannes SchindelinJan 12, 2016
  6. Junio C HamanoJan 12, 2016
  7. Jeff KingJan 12, 2016
  8. Junio C HamanoJan 13, 2016
  9. Jeff KingJan 13, 2016
  10. Junio C HamanoJan 13, 2016
  11. Junio C HamanoJan 13, 2016
  12. Jeff KingJan 14, 2016
  13. David A. GreeneJan 13, 2016
  14. Michael J GruberJan 18, 2016
  15. Jeff KingJan 18, 2016
  16. Eric WongJan 18, 2016
  17. Michael J GruberJan 19, 2016
  18. Duy NguyenJan 25, 2016
  19. Junio C HamanoJan 25, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.