git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [ANNOUNCE] Git v2.11.0-rc0

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 1, 2016, 22:06 UTC
Message-ID
<xmqqr36un9d2.fsf@gitster.mtv.corp.google.com>
In-Reply-To
<CAGZ79kZHajTxFRbOftH==UAXhbH7RSA_jYWO-aQXhW2aSRdUFA@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
Show 11 quoted lines
>> -diff.indentHeuristic::
>>  diff.compactionHeuristic::
>>         Set one of these options to `true` to enable one of two
>>         experimental heuristics that shift diff hunk boundaries to
>
> We would need to reword this as well, as there will be only one heuristic left?
>> +               } else if (flags & XDF_COMPACTION_HEURISTIC) {
>>                         /*
>>                          * Indent heuristic: a group of pure add/delete lines
>
> This comment may need adjustment as well (though we could go without)
Thanks.  I've queued this as "SQUASH???" on top.
diff --git a/Documentation/diff-config.txt b/Documentation/diff-config.txt
index 0c79e48d9d..39fff3aef9 100644
--- a/Documentation/diff-config.txt
+++ b/Documentation/diff-config.txt
@@ -172,9 +172,8 @@ diff.tool::
 include::mergetools-diff.txt[]
 
 diff.compactionHeuristic::
-	Set one of these options to `true` to enable one of two
-	experimental heuristics that shift diff hunk boundaries to
-	make patches easier to read.
+	Set this option to `true` to enable experimental heuristics
+	that shift diff hunk boundaries to make patches easier to read.
 
 diff.algorithm::
 	Choose a diff algorithm.  The variants are as follows:
diff --git a/xdiff/xdiffi.c b/xdiff/xdiffi.c
index 6cb96219cb..31ff519232 100644
--- a/xdiff/xdiffi.c
+++ b/xdiff/xdiffi.c
@@ -908,7 +908,9 @@ int xdl_change_compact(xdfile_t *xdf, xdfile_t *xdfo, long flags) {
 			}
 		} else if (flags & XDF_COMPACTION_HEURISTIC) {
 			/*
-			 * Indent heuristic: a group of pure add/delete lines
+			 * Heuristic based on the indentation level.
+			 *
+			 * A group of pure add/delete lines
 			 * implies two splits, one between the end of the "before"
 			 * context and the start of the group, and another between
 			 * the end of the group and the beginning of the "after"
Previous: Stefan BellerNext: Junio C Hamano
Message 10 of 16 in “[ANNOUNCE] Git v2.11.0-rc0”
  1. Junio C HamanoOct 31, 2016
  2. Simon RuderichOct 31, 2016
  3. Patrick SteinhardtNov 1, 2016
  4. Jeff KingNov 1, 2016
  5. Junio C HamanoNov 1, 2016
  6. Jeff KingNov 1, 2016
  7. Junio C HamanoNov 1, 2016
  8. Junio C HamanoNov 1, 2016
  9. Stefan BellerNov 1, 2016
  10. Junio C HamanoNov 1, 2016
  11. Junio C HamanoNov 1, 2016
  12. Jeff KingNov 1, 2016
  13. Michael HaggertyNov 2, 2016
  14. Stefan BellerNov 1, 2016
  15. Jacob KellerNov 2, 2016
  16. Stefan BellerNov 1, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.