Re: [ANNOUNCE] Git v2.11.0-rc0
- From
Jacob Keller <jacob.keller@gmail.com>
- Date
- Nov 2, 2016, 01:21 UTC
- Message-ID
- <CA+P7+xq0YG5RTg8MSofd4h3AYMxe1OqtSeZeyXUvP_fZEypiSQ@mail.gmail.com>
- In-Reply-To
- <CAGZ79ka6un7nHaNk3F8yp3vFSnB-iGapqLcZ-ZC3EvcKE4DMNQ@mail.gmail.com>
On Tue, Nov 1, 2016 at 2:10 PM, Stefan Beller <sbeller@google.com> wrote:
Show 21 quoted lines
> On Tue, Nov 1, 2016 at 1:59 PM, Jeff King <peff@peff.net> wrote: >> On Tue, Nov 01, 2016 at 01:56:34PM -0700, Junio C Hamano wrote: >> >>> > As of -rc0, we have both --indent-heuristic and --compaction-heuristic >>> > (along with matching config), and they are mutually exclusive. >>> > >>> > In [1], Stefan suggested just replacing the compaction heuristic >>> > entirely with the new one (and you seemed to agree). If we're going to >>> > do that, it makes sense to do so before the release, so that we don't >>> > get stuck supporting --indent-heuristic forever. >>> >>> You meant "compaction" in the last part? I think it is probably a >>> good idea. >> >> I thought the plan mentioned in the mail I linked was to keep the indent >> heuristic, but simply _call_ it the compaction heuristic. IOW, to swap >> out the implementation under the hood for something we know is better. > > AFAICT Michaels design is better in every aspect than what I did initially, > so it supersedes the work I did there. I would support the swap in names. >
Agreed, it's much better than the original idea, and results in better diffs in every single case we could find.
Show 6 quoted lines
>> >> We've already released a version with --compaction-heuristic, so we are >> stuck keeping it forever either way. > > IIRC the release notes specifically noted this flag to be experimental and > may be removed in future versions.
I agree, I think that we specifically spelled out that this might go away, and so I don't think we're stuck supporting it forever. We don't even really need a deprecation time frame either.
Show 5 quoted lines
> > When not doing the swap of the implementation, but rather remove the > experimental feature of compaction-heuristic and introducing a *new* > experimental --indent-heuristic, this may drive the point across that > these names are actually experimental.
I think we should swap names as "compaction heuristic" is more generic.
Thanks, Jake