git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 0/3] Fix curl_easy_setopt() parameter type problem, again

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 26, 2025, 17:40 UTC
Message-ID
<xmqqo6qxaz8n.fsf@gitster.g>
In-Reply-To
<pull.1974.v2.git.1758882772.gitgitgadget@gmail.com>

"Johannes Schindelin via GitGitGadget" <gitgitgadget@gmail.com> writes:

Show 20 quoted lines
> As of last week, every CI build of Git for Windows' ARM64 flavor of its SDK
> started failing (the first failed build is this here:
> https://github.com/git-for-windows/git-sdk-arm64/actions/runs/17633130672/job/50104373185).
> ..
> For the record, these patches apply cleanly all the way back to v2.22,
> according to git replay. I did not try to test whether it builds, though,
> because all kinds of stunts are required nowadays to build this old versions
> even without any patches on top.
> Range-diff vs v1:
>
>  1:  7caaec9102 ! 1:  114eb9c8ec http: offer to cast `size_t` to `curl_off_t` safely
>      @@ Commit message
>           naming convention of the helper functions that safely cast from one data
>           type to another which has been well established in `git-compat-util.h`.
>       
>      -    With this move, the error message can unfortunately no longer be renamed
>      -    because the `_(...)` function is not available at the time of
>      -    definition.
>      +    With this move, `gettext.h` must be `#include`d in `http.h` to allow the
>      +    error message to remain translatable.
Ahh, OK.  Now I understand that's what you meant.
Show 9 quoted lines
>  2:  e1d5a85f70 ! 2:  fdd1327e7b imap-send: be more careful when casting to `curl_off_t`
>      @@ Commit message
>           imap-send: be more careful when casting to `curl_off_t`
>       
>           When casting a `size_t` to `curl_off_t`, there is a currently uncommon
>      -    chance that the value can be cut off (`curl_off_t` is supposed to be
>      -    guaranteed to be 64-bit).
>      +    chance that the value can be cut off (`curl_off_t` is expected to be a
>      +    signed 64-bit data type).
Will replace.  Let me mark the topic for 'next'.
Thanks.
Previous: Johannes Schindelin via GitGitGadget
Message 12 of 12 in “Fix curl_easy_setopt() parameter type problem, again”
  1. 0/3 Fix curl_easy_setopt() parameter type problem, againJohannes Schindelin via GitGitGadget, Sep 21, 2025
  2. 1/3 http: offer to cast `size_t` to `curl_off_t` safelyJohannes Schindelin via GitGitGadget, Sep 21, 2025
  3. Junio C HamanoSep 21, 2025
  4. 2/3 imap-send: be more careful when casting to `curl_off_t`Johannes Schindelin via GitGitGadget, Sep 21, 2025
  5. Junio C HamanoSep 21, 2025
  6. 3/3 http-push: avoid new compile errorJohannes Schindelin via GitGitGadget, Sep 21, 2025
  7. Junio C HamanoSep 21, 2025
  8. 0/3 Fix curl_easy_setopt() parameter type problem, againJohannes Schindelin via GitGitGadget, Sep 26, 2025
  9. 1/3 http: offer to cast `size_t` to `curl_off_t` safelyJohannes Schindelin via GitGitGadget, Sep 26, 2025
  10. 2/3 imap-send: be more careful when casting to `curl_off_t`Johannes Schindelin via GitGitGadget, Sep 26, 2025
  11. 3/3 http-push: avoid new compile errorJohannes Schindelin via GitGitGadget, Sep 26, 2025
  12. Junio C HamanoSep 26, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.