From: Junio C Hamano Date: Fri, 26 Sep 2025 17:40:40 GMT Subject: Re: [PATCH v2 0/3] Fix curl_easy_setopt() parameter type problem, again Message-ID: In-Reply-To: "Johannes Schindelin via GitGitGadget" writes: > As of last week, every CI build of Git for Windows' ARM64 flavor of its SDK > started failing (the first failed build is this here: > https://github.com/git-for-windows/git-sdk-arm64/actions/runs/17633130672/job/50104373185). > .. > For the record, these patches apply cleanly all the way back to v2.22, > according to git replay. I did not try to test whether it builds, though, > because all kinds of stunts are required nowadays to build this old versions > even without any patches on top. > Range-diff vs v1: > > 1: 7caaec9102 ! 1: 114eb9c8ec http: offer to cast `size_t` to `curl_off_t` safely > @@ Commit message > naming convention of the helper functions that safely cast from one data > type to another which has been well established in `git-compat-util.h`. > > - With this move, the error message can unfortunately no longer be renamed > - because the `_(...)` function is not available at the time of > - definition. > + With this move, `gettext.h` must be `#include`d in `http.h` to allow the > + error message to remain translatable. Ahh, OK. Now I understand that's what you meant. > 2: e1d5a85f70 ! 2: fdd1327e7b imap-send: be more careful when casting to `curl_off_t` > @@ Commit message > imap-send: be more careful when casting to `curl_off_t` > > When casting a `size_t` to `curl_off_t`, there is a currently uncommon > - chance that the value can be cut off (`curl_off_t` is supposed to be > - guaranteed to be 64-bit). > + chance that the value can be cut off (`curl_off_t` is expected to be a > + signed 64-bit data type). Will replace. Let me mark the topic for 'next'. Thanks.