Re: [PATCH v3 04/14] dir: convert struct sha1_stat to use object_id
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 24, 2018, 21:36 UTC
- Message-ID
- <xmqqmv13aqig.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <d7d2ff4d0d18ff381d023d0d2451d161d74a191c.1516790478.git.patryk.obara@gmail.com>
Patryk Obara <patryk.obara@gmail.com> writes:
> Convert the declaration of struct sha1_stat. Adjust all usages of this
> struct and replace hash{clr,cmp,cpy} with oid{clr,cmp,cpy} wherever
> possible. Rename it to struct oid_stat.OK, but a hunk like this makes readers wonder...
Show 6 quoted lines
> -static int do_read_blob(const struct object_id *oid, > - struct sha1_stat *sha1_stat, > - size_t *size_out, > - char **data_out) > +static int do_read_blob(const struct object_id *oid, struct oid_stat *sha1_stat, > + size_t *size_out, char **data_out)
... why the variable is still called sha1_stat, not oid_stat. Is it because it makes the patch too noisy or something?
> Remove macro EMPTY_BLOB_SHA1_BIN, as it's no longer used.
Good.