Re: [PATCH v2] diff: disable compaction heuristic for now
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 10, 2016, 20:55 UTC
- Message-ID
- <xmqqk2hwepcq.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <xmqqoa78epmt.fsf_-_@gitster.mtv.corp.google.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 11 quoted lines
> Jeff King <peff@peff.net> writes: > > > We probably want a patch to the release notes to note that it's not on > > by default. And we may want to advertise the experimental knob so > > that people actually try it (otherwise we won't get feedback from the > > masses). > > OK, I think that is sensible. The interdiff is not a strict > reversion of 77085a61 (diff: undocument the compaction heuristic > knobs for experimentation, 2016-05-02) but stresses that the > feature is off by default and is experimental.
This is for 'master' when the topic is merged (will keep it in stash for now).
Documentation/RelNotes/2.9.0.txt | 8 +++++--- 1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/Documentation/RelNotes/2.9.0.txt b/Documentation/RelNotes/2.9.0.txt index 927cb9b..79b46e1 100644 --- a/Documentation/RelNotes/2.9.0.txt +++ b/Documentation/RelNotes/2.9.0.txt @@ -118,9 +118,11 @@ UI, Workflows & Features * HTTP transport clients learned to throw extra HTTP headers at the server, specified via http.extraHeader configuration variable. - * Patch output from "git diff" and friends has been tweaked to be - more readable by using a blank line as a strong hint that the - contents before and after it belong to logically separate units. + * The "--compaction-heuristic" option to "git diff" family of + commands enables a heuristic to make the patch output more readable + by using a blank line as a strong hint that the contents before and + after it belong to logically separate units. It is still + experimental. * A new configuration variable core.hooksPath allows customizing where the hook directory is.