git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 0/5] mingw: handle absolute paths in expand_user_path()

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 26, 2021, 17:56 UTC
Message-ID
<xmqqk0ldj6w3.fsf@gitster.g>
In-Reply-To
<pull.66.v3.git.1627164413.gitgitgadget@gmail.com>

"Johannes Schindelin via GitGitGadget" <gitgitgadget@gmail.com> writes:

>  * Since our convention of %(...) interpolation does not involve uppercase
>    keywords, I now use a lowercase one.
Makes sense.
>  * Since this keyword is interpolated to the compiled-in prefix if built
>    without runtime prefix support, I dropped the runtime part of the
>    keyword.

I have this nagging feeling that %(prefix) may be (mistakenly) expected to interporate to $(git rev-parse --show-prefix). Of course, nobody would expect that in paths in the configuration files, but because we are borrowing %(token) convention from elsewhere, it is not outragous to imagine that either "for-each-ref" family or "log" family of placeholders may want to use %(prefix)" for such purpose (for that matter, they may also be helped to have the runtime-prefix information available).

Perhaps %(installPrefix) or something may have less chance of making us regret later. I am just raising this as a possible problem; I personally would not be confused if we settled on the %(prefix).

>  * Renamed the expand_user_path() to interpolate_path(), to remove the
>    distraction as to the implementation detail which things get to be
>    interpolated (because we extend it to interpolate more than just a home
>    directory, which might well be unclear from the former name, anyway).
Great.
>  * Adjusted the code comment above the interpolate_path() to remove a stale
>    part, clarify another part, and to extend it to talk about the prefix
>    expansion, too.
These looked good, too.
Thanks.
Previous: Johannes Schindelin via GitGitGadget
Message 53 of 53 in “mingw: handle absolute paths in expand_user_path()”
  1. 0/1 mingw: handle absolute paths in expand_user_path()Johannes Schindelin via GitGitGadget, Nov 6, 2018
  2. 1/1 mingw: handle absolute paths in expand_user_path()Johannes Schindelin via GitGitGadget, Nov 6, 2018
  3. Ramsay JonesNov 6, 2018
  4. Ramsay JonesNov 6, 2018
  5. Duy NguyenNov 6, 2018
  6. Junio C HamanoNov 7, 2018
  7. Johannes SchindelinNov 7, 2018
  8. Ramsay JonesNov 7, 2018
  9. Junio C HamanoNov 8, 2018
  10. Johannes SchindelinNov 8, 2018
  11. Junio C HamanoNov 8, 2018
  12. Johannes SchindelinNov 8, 2018
  13. Joseph MoisanNov 9, 2018
  14. Jeff KingNov 9, 2018
  15. Duy NguyenNov 6, 2018
  16. Johannes SchindelinNov 7, 2018
  17. Johannes SixtNov 6, 2018
  18. Johannes SchindelinNov 7, 2018
  19. Johannes SixtNov 7, 2018
  20. Jeff KingNov 7, 2018
  21. Johannes SixtNov 7, 2018
  22. Jeff KingNov 7, 2018
  23. Junio C HamanoNov 8, 2018
  24. Jeff KingNov 8, 2018
  25. Junio C HamanoNov 8, 2018
  26. Johannes SchindelinNov 8, 2018
  27. Duy NguyenNov 8, 2018
  28. Johannes SchindelinNov 8, 2018
  29. Eric SunshineNov 8, 2018
  30. Jeff KingNov 9, 2018
  31. Duy NguyenNov 9, 2018
  32. Junio C HamanoNov 12, 2018
  33. Junio C HamanoNov 8, 2018
  34. Johannes SchindelinNov 8, 2018
  35. 0/2 mingw: handle absolute paths in expand_user_path()Johannes Schindelin via GitGitGadget, Jul 1, 2021
  36. 1/2 tests: exercise the RUNTIME_PREFIX featureJohannes Schindelin via GitGitGadget, Jul 1, 2021
  37. 2/2 expand_user_path(): support specifying paths relative to the runtime prefixJohannes Schindelin via GitGitGadget, Jul 1, 2021
  38. Junio C HamanoJul 1, 2021
  39. 0/5 mingw: handle absolute paths in expand_user_path()Johannes Schindelin via GitGitGadget, Jul 24, 2021
  40. 1/5 tests: exercise the RUNTIME_PREFIX featureJohannes Schindelin via GitGitGadget, Jul 24, 2021
  41. 3/5 expand_user_path(): clarify the role of the `real_home` parameterJohannes Schindelin via GitGitGadget, Jul 24, 2021
  42. 4/5 Use a better name for the function interpolating pathsJohannes Schindelin via GitGitGadget, Jul 24, 2021
  43. Junio C HamanoJul 26, 2021
  44. Fabian StelzerJul 27, 2021
  45. Junio C HamanoJul 27, 2021
  46. Junio C HamanoJul 28, 2021
  47. Junio C HamanoJul 28, 2021
  48. Junio C HamanoJul 28, 2021
  49. Fabian StelzerJul 28, 2021
  50. Junio C HamanoJul 28, 2021
  51. 2/5 expand_user_path(): remove stale part of the commentJohannes Schindelin via GitGitGadget, Jul 24, 2021
  52. 5/5 interpolate_path(): allow specifying paths relative to the runtime prefixJohannes Schindelin via GitGitGadget, Jul 24, 2021
  53. Junio C HamanoJul 26, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.