Re: [PATCH v5 1/2] checkout: improve message for ambiguous remote branch name
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 20, 2026, 02:18 UTC
- Message-ID
- <xmqqjyplttzr.fsf@gitster.g>
- In-Reply-To
- <CALnO6CCQppTnw1Y-6ibmcko0dM3hy8riPanD9BNyb+MW8a5nAw@mail.gmail.com>
"D. Ben Knoble" <ben.knoble@gmail.com> writes:
>> +static void be_explicit(const char *branch, > > Be explicit about what? Reading below, a better name might be > "advise_ambiguous_remote_branch_name" or something, idk.
It stands for "tell the user to be more explicit". I agree with you that the refactoring should be done as a separate step, on top of which we should add the new feature, i.e., "give list of possible candidates", as a separate step.