From: Junio C Hamano Date: Thu, 20 Aug 2026 02:18:16 GMT Subject: Re: [PATCH v5 1/2] checkout: improve message for ambiguous remote branch name Message-ID: In-Reply-To: "D. Ben Knoble" writes: >> +static void be_explicit(const char *branch, > > Be explicit about what? Reading below, a better name might be > "advise_ambiguous_remote_branch_name" or something, idk. It stands for "tell the user to be more explicit". I agree with you that the refactoring should be done as a separate step, on top of which we should add the new feature, i.e., "give list of possible candidates", as a separate step.