Re: [PATCH v9 1/4] checkout: extract function to display advice for ambiguous remotes
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 26, 2026, 15:24 UTC
- Message-ID
- <xmqq4iggkiq2.fsf@gitster.g>
- In-Reply-To
- <e3f7d885209e6cf9487bea296bc81df43f3758db.1787741111.git.gitgitgadget@gmail.com>
"Yoichi NAKAYAMA via GitGitGadget" <gitgitgadget@gmail.com> writes:
> From: Yoichi NAKAYAMA <yoichi.nakayama@gmail.com> > > Signed-off-by: Yoichi NAKAYAMA <yoichi.nakayama@gmail.com>
Don't we want to describe a bit of explanation between these two lines? There are a few things that immediately come to mind as motivation for such changes, like that the original place was too deeply nested, that the original code was incorrectly indented, and that we are going to extend this function in later steps in the series.
> +static void advice_disambiguating_remotes(enum checkout_command which_command)
> +{[2/4] updates this function to a better name; let's give it that name from the beginning.