Re: [PATCH] general style: replaces memcmp() with proper starts_with()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 12, 2014, 19:39 UTC
- Message-ID
- <xmqqiorjky0a.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <20140312175624.GA7982@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 16 quoted lines
>> static inline int standard_header_field(const char *field, size_t len)
>> {
>> - return ((len == 4 && !memcmp(field, "tree ", 5)) ||
>> - (len == 6 && !memcmp(field, "parent ", 7)) ||
>> - (len == 6 && !memcmp(field, "author ", 7)) ||
>> - (len == 9 && !memcmp(field, "committer ", 10)) ||
>> - (len == 8 && !memcmp(field, "encoding ", 9)));
>> + return ((len == 4 && starts_with(field, "tree ")) ||
>> + (len == 6 && starts_with(field, "parent ")) ||
>> + (len == 6 && starts_with(field, "author ")) ||
>> + (len == 9 && starts_with(field, "committer ")) ||
>> + (len == 8 && starts_with(field, "encoding ")));
>
> These extra "len" checks are interesting. They look like an attempt to
> optimize lookup, since the caller will already have scanned forward to
> the space.If one really wants to remove the magic constants from this, then one must take advantage of the pattern
len == strlen(S) - 1 && !memcmp(field, S, strlen(S))
that appears here, and come up with a simple abstraction to express that we are only using the string S (e.g. "tree "), length len and location field of the counted string.
Blindly replacing starts_with() with !memcmp() in the above part is a readability regression otherwise.
> ... I > think with a few more helpers we could really further clean up some of > these callsites.
Yes.