git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] launch_editor(): indicate that Git waits for user input

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 18, 2017, 01:40 UTC
Message-ID
<xmqqh8tsqs83.fsf@gitster.mtv.corp.google.com>
In-Reply-To
<CAPig+cQ3a0guJUhnbktrjs6fL6mSrUXmPqR0BafEAOhVr7Sy-w@mail.gmail.com>
Eric Sunshine <sunshine@sunshineco.com> writes:
Show 11 quoted lines
>> @@ -40,6 +40,32 @@ int launch_editor(const char *path, struct strbuf *buffer, const char *const *en
>> +               static const char *close_notice = NULL;
>> +
>> +               if (isatty(2) && !close_notice) {
>
> If you reverse this condition to say (!close_notice && isatty(2)),
> then you save an isatty() invocation each time if close_notice is
> already assigned.
>
> However, it's not clear how much benefit you gain from stashing this
> away in a static variable. Premature optimization?

The variable being "static" could be (but it was done primarily because it allowed me not to worry about freeing), but during a single invocation, it primarily is used as a flag "are we showing the editor invocation notice?" two places in the function can use without having to do the same checks twice.

If we want this as an optimization "we've already checked the condition in our previous call, so let's use the result without checking again", then this has to become tristate:

 - We haven't checked, and needs checking (probably NULL);
 - We have checked, and we know we want to show the notice---here is
   a string to use when we clear the notice (what we have here);
 - We have checked, and we know we do not want to show the notice
   (there is no provision for this in the posted code---that makes
   this not an optimization yet).

Perhaps an empty string can be used for the last one, but if/when it is done, the above needs to go in a comment near the definition of the variable.

Show 6 quoted lines
> Should printing of close_notice be done before the error()? Otherwise,
> you get this:
>
> --- 8< ---
> Launched your editor (...) ...There was a problem...
> --- 8< ---

In my version with a far shorter message, I deliberately chose not to clear the notice. We ran the editor, and we saw a problem. That is what happened and that is what will be left on the terminal.

I agree that the verbose message Lars substituted makes it harder to read.

Previous: Eric SunshineNext: Kaartic Sivaraam
Message 5 of 12 in “launch_editor(): indicate that Git waits for user input”
  1. launch_editor(): indicate that Git waits for user inputlars.schneider@autodesk.com, Nov 17, 2017
  2. Junio C HamanoNov 17, 2017
  3. Lars SchneiderNov 22, 2017
  4. Eric SunshineNov 17, 2017
  5. Junio C HamanoNov 18, 2017
  6. Kaartic SivaraamNov 19, 2017
  7. Junio C HamanoNov 20, 2017
  8. Lars SchneiderNov 22, 2017
  9. Kaartic SivaraamNov 22, 2017
  10. Junio C HamanoNov 24, 2017
  11. Lars SchneiderNov 22, 2017
  12. Eric SunshineNov 22, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.