Re: [PATCH 4/6] fetch-pack: refactor command and capability write
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 9, 2021, 05:27 UTC
- Message-ID
- <xmqqh7kgni2q.fsf@gitster.g>
- In-Reply-To
- <7988c106873332ac6e5c2f9dd143cfa1f50e067c.1617929278.git.jonathantanmy@google.com>
Jonathan Tan <jonathantanmy@google.com> writes:
> A subsequent commit will need this functionality independent of the rest > of send_fetch_request(), so put this into its own function.
OK. send_fetch_request() used to do the "command=fetch", capability response, and concluded them with a delim packet, which is now done with the new helper write_fetch_command_and_capabilities().
Mostly code movement, without any behaviour change.
Makes sense.