git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 6/6] send-pack: support push negotiation

From
Derrick Stolee <stolee@gmail.com>
Date
May 4, 2021, 17:26 UTC
Message-ID
<70ea6b85-bc73-3f39-3449-9c08f6738a73@gmail.com>
In-Reply-To
<20210503220244.2878522-1-jonathantanmy@google.com>
On 5/3/2021 6:02 PM, Jonathan Tan wrote:
Show 25 quoted lines
> [snip asking about whether extra_have (a.k.a. advertised) and commons (a.k.a.
> negotiated) can be merged]
> 
>> Here, it would be nice if extra_have and commons were merged before calling
>> pack_objects(). I mentioned a way to perhaps make that easier above, but
>> the context might not make that be super-simple. Running a loop here to
>> scan 'commons' and append them to 'extra_have' might be a sufficient
>> approach.
>>
>> Generally, this approach seems like it would work. I have not done any
>> local testing, yet.
>>
>> Thanks,
>> -Stolee
> 
> I was reluctant to merge them because that would involve either (1)
> adding commons to "extra_have" (as you suggest) or (2) iterating through
> "extra_have" in order to add it to the "commons" set. For (1), this
> would modify "extra_have", which is passed in from the outside. Looking
> at its callers, the main one in git_transport_push() in transport.c
> calls send_pack() with a set that has traversed the transport API, so I
> think it would be confusing if such a set suddenly changed. For (2), the
> extra loop seems more troublesome than having two parameters with
> clearer names indicating where they come from. I don't mind changing to
> (2), though, if people want it.
 
I suppose this concern about "ownership" is valid and worth having the
two parameters in the helper function for extra safety.

Thanks, -Stolee

Previous: Jonathan TanNext: Junio C Hamano
Message 21 of 33 in “Push negotiation”
  1. 0/6 Push negotiationJonathan Tan, Apr 9, 2021
  2. 1/6 fetch-pack: buffer object-format with other argsJonathan Tan, Apr 9, 2021
  3. Junio C HamanoApr 9, 2021
  4. Jonathan TanApr 9, 2021
  5. 2/6 fetch-pack: refactor process_acks()Jonathan Tan, Apr 9, 2021
  6. Junio C HamanoApr 9, 2021
  7. Derrick StoleeMay 3, 2021
  8. 3/6 fetch-pack: refactor add_haves()Jonathan Tan, Apr 9, 2021
  9. Junio C HamanoApr 9, 2021
  10. 4/6 fetch-pack: refactor command and capability writeJonathan Tan, Apr 9, 2021
  11. Junio C HamanoApr 9, 2021
  12. 5/6 fetch: teach independent negotiation (no packfile)Jonathan Tan, Apr 9, 2021
  13. Junio C HamanoApr 9, 2021
  14. Jonathan TanApr 9, 2021
  15. Derrick StoleeMay 3, 2021
  16. Derrick StoleeMay 3, 2021
  17. Jonathan TanMay 3, 2021
  18. 6/6 send-pack: support push negotiationJonathan Tan, Apr 9, 2021
  19. Derrick StoleeMay 3, 2021
  20. Jonathan TanMay 3, 2021
  21. Derrick StoleeMay 4, 2021
  22. Junio C HamanoApr 30, 2021
  23. Derrick StoleeApr 30, 2021
  24. 0/5 Push negotiationJonathan Tan, May 4, 2021
  25. 1/5 fetch-pack: refactor process_acks()Jonathan Tan, May 4, 2021
  26. 2/5 fetch-pack: refactor add_haves()Jonathan Tan, May 4, 2021
  27. 3/5 fetch-pack: refactor command and capability writeJonathan Tan, May 4, 2021
  28. 4/5 fetch: teach independent negotiation (no packfile)Jonathan Tan, May 4, 2021
  29. Junio C HamanoMay 5, 2021
  30. Derrick StoleeMay 5, 2021
  31. Junio C HamanoMay 6, 2021
  32. Derrick StoleeMay 5, 2021
  33. 5/5 send-pack: support push negotiationJonathan Tan, May 4, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.