git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] config.txt: stick to CamelCase naming convention

From
Junio C Hamano <gitster@pobox.com>
Date
Mar 10, 2015, 23:22 UTC
Message-ID
<xmqqfv9cxwsm.fsf@gitster.dls.corp.google.com>
In-Reply-To
<CAPig+cRkV++D9-yYWOv3FmBtTuWz1_Et23Xk=8cg8=7_E1PZug@mail.gmail.com>
Eric Sunshine <sunshine@sunshineco.com> writes:
Show 8 quoted lines
>> @@ -2308,14 +2308,14 @@ sendemail.identity::
>>         See linkgit:git-send-email[1] for description.  Note that this
>>         setting is not subject to the 'identity' mechanism.
>>
>> -sendemail.smtpssl (deprecated)::
>> +sendemail.smtpSSL (deprecated)::
>
> Here, "SSL"...

and not "SMTP". Now what should the rule be when two acronyms sit next to each other?

I personally feel that we should first fix the obvious "multipleWords" ones without worrying about abbreviations like ctx and acronyms and then debate to come up with the rules for the latter two classes. Most of the ones in the patch look like "multipleWords" kind that should be uncontroversial.

Duy, thanks for starting this.
Previous: Eric SunshineNext: Nguyễn Thái Ngọc Duy
Message 5 of 7 in “config.txt: stick to CamelCase naming convention”
  1. config.txt: stick to CamelCase naming conventionNguyễn Thái Ngọc Duy, Mar 10, 2015
  2. Torsten BögershausenMar 10, 2015
  3. Duy NguyenMar 11, 2015
  4. Eric SunshineMar 10, 2015
  5. Junio C HamanoMar 10, 2015
  6. *config.txt: stick to camelCase naming conventionNguyễn Thái Ngọc Duy, Mar 11, 2015
  7. Eric SunshineMar 11, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.