git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] config.txt: stick to CamelCase naming convention

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Mar 10, 2015, 20:34 UTC
Message-ID
<CAPig+cRkV++D9-yYWOv3FmBtTuWz1_Et23Xk=8cg8=7_E1PZug@mail.gmail.com>
In-Reply-To
<1425983981-634-1-git-send-email-pclouds@gmail.com>
On Tue, Mar 10, 2015 at 6:39 AM, Nguyễn Thái Ngọc Duy <pclouds@gmail.com> wrote:
Show 12 quoted lines
> Signed-off-by: Nguyễn Thái Ngọc Duy <pclouds@gmail.com>
> ---
> diff --git a/Documentation/config.txt b/Documentation/config.txt
> index 1530255..b4cc577 100644
> --- a/Documentation/config.txt
> +++ b/Documentation/config.txt
> @@ -257,20 +257,20 @@ core.protectNTFS::
>         8.3 "short" names.
>         Defaults to `true` on Windows, and `false` elsewhere.
>
> -core.trustctime::
> +core.trustCTime::

I personally find this a bit odd. 'ctime' is always typed exactly like that; never 'cTime' or 'Ctime' or 'CTime'.

Show 12 quoted lines
>         If false, the ctime differences between the index and the
>         working tree are ignored; useful when the inode change time
>         is regularly modified by something outside Git (file system
>         crawlers and some backup systems).
>         See linkgit:git-update-index[1]. True by default.
>
> @@ -290,7 +290,7 @@ core.eol::
>         linkgit:gitattributes[5] for more information on end-of-line
>         conversion.
>
> -core.safecrlf::
> +core.safeCRLF::
Here, you uppercase the entire acronym, "CRLF"...
Show 9 quoted lines
>         If true, makes Git check if converting `CRLF` is reversible when
>         end-of-line conversion is active.  Git will verify if a command
>         modifies a file in the work tree either directly or indirectly.
> @@ -1281,11 +1281,11 @@ gitcvs.enabled::
>         Path to a log file where the CVS server interface well... logs
>         various stuff. See linkgit:git-cvsserver[1].
>
> -gitcvs.usecrlfattr::
> +gitcvs.useCrlfAttr::
But, here you only capitalized it: "Crlf".
Show 9 quoted lines
>         If true, the server will look up the end-of-line conversion
>         attributes for files to determine the '-k' modes to use. If
>         the attributes force Git to treat a file as text,
> @@ -1403,39 +1403,39 @@ gui.encoding::
>         "true" if linkgit:git-gui[1] should prune remote-tracking branches when
>         performing a fetch. The default value is "false".
>
> -gui.trustmtime::
> +gui.trustMTime::

Ditto comment regarding strangeness of seeing 'mtime' typed any way other than 'mtime'.

Show 9 quoted lines
>         Determines if linkgit:git-gui[1] should trust the file modification
>         timestamp or not. By default the timestamps are not trusted.
>
>         Specifies the threshold to use in 'git gui blame' original location
>         detection, measured in alphanumeric characters. See the
>         linkgit:git-blame[1] manual for more information on copy detection.
>
> -gui.blamehistoryctx::
> +gui.blameHistoryCTX::

You've uppercased acronyms (such as CRLF, URL, SSL), however, "ctx" is merely an abbreviation of "context", not an acronym. As such, "Ctx" seems more correct.

Show 9 quoted lines
>         Specifies the radius of history context in days to show in
>         linkgit:gitk[1] for the selected commit, when the `Show History
>         Context` menu item is invoked from 'git gui blame'. If this
> @@ -2308,14 +2308,14 @@ sendemail.identity::
>         See linkgit:git-send-email[1] for description.  Note that this
>         setting is not subject to the 'identity' mechanism.
>
> -sendemail.smtpssl (deprecated)::
> +sendemail.smtpSSL (deprecated)::
Here, "SSL"...
>         Deprecated alias for 'sendemail.smtpencryption = ssl'.
>
> -sendemail.smtpsslcertpath::
> +sendemail.smtpSslCertPath::
But here, inconsistently, "Ssl".
>         Path to ca-certificates (either a directory or a single file).
>         Set it to an empty string to disable certificate verification.
>
Previous: Duy NguyenNext: Junio C Hamano
Message 4 of 7 in “config.txt: stick to CamelCase naming convention”
  1. config.txt: stick to CamelCase naming conventionNguyễn Thái Ngọc Duy, Mar 10, 2015
  2. Torsten BögershausenMar 10, 2015
  3. Duy NguyenMar 11, 2015
  4. Eric SunshineMar 10, 2015
  5. Junio C HamanoMar 10, 2015
  6. *config.txt: stick to camelCase naming conventionNguyễn Thái Ngọc Duy, Mar 11, 2015
  7. Eric SunshineMar 11, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.