Re: [RFC/PATCH 1/2] submodule: implement `module_list` as a builtin helper
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 3, 2015, 21:38 UTC
- Message-ID
- <xmqqfv406ojg.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <CAGZ79kY=39j4H=62=VZRm4VOcqzgOAU6tDpJVsqdeqnPtB8hQQ@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
>> $ git submodule--helper module_list > > Why would you use an underscore in here as opposed to a dash?
Simply because the diff would be easier to read; the callers used to call module_list shell function, now they call the subcommand with the same name of submodule--helper.