Re: [PATCHv3 1/9] t7408: modernize style
Eric Sunshine <sunshine@sunshineco.com> writes:
Show 20 quoted lines
> On Tue, Aug 9, 2016 at 12:08 AM, Stefan Beller <sbeller@google.com> wrote:
>> t7408: modernize style
>>
>> Signed-off-by: Stefan Beller <sbeller@google.com>
>> ---
>> diff --git a/t/t7408-submodule-reference.sh b/t/t7408-submodule-reference.sh
>> @@ -8,74 +8,76 @@ test_description='test clone --reference'
>> +test_expect_success 'that reference gets used with add' '
>> + (
>> + cd super/sub &&
>> + echo "0 objects, 0 kilobytes" > expected &&
>
> Since you're modernizing the style, perhaps drop the space after '>'
> here and elsewhere.
>
>> + git count-objects > current &&
>> + diff expected current
>
> Modern practice is to call this 'actual' rather than 'current', but
> perhaps that's outside the scope of this patch(?).
Not just that, modern practice is to use "test_cmp" not "diff".