git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 2/6] push: move code to setup_push_simple()

From
Junio C Hamano <gitster@pobox.com>
Date
May 31, 2021, 05:04 UTC
Message-ID
<xmqqczt7xzm4.fsf@gitster.g>
In-Reply-To
<20210529071115.1908310-3-felipe.contreras@gmail.com>
Felipe Contreras <felipe.contreras@gmail.com> writes:
> In order to avoid doing unnecessary things and simplify it in further
> patches.
>
> The code is copied exactly as-is; no functional changes.

The title says "move" and I expected to see corresponding deletions, but it seems that this (possibly temporarily) duplicates what these two functions do, without removing them, which (possibly temporarily) risks the two to drift apart. So, the resulting code from this step will do nothing wrong (it's just two function's bodies inlined in duplicated form), but depending on how the code evolves, it might turn out to be a good change or a bad change---we cannot judge by this step alone.

From a quick scanning of the remainder of the series, it seems that 3/6 and 4/6 improve the copied code without changing the behaviour, and at the end these two functions remain, so we have duplicated logic for these two functions and improvements only live in one of the copies (namely, in the setup_push_simple())? Would that be a problem, or it is too much work to do better, I wonder?

Let's keep reading.
Show 53 quoted lines
> Reviewed-by: Elijah Newren <newren@gmail.com>
> Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
> ---
>  builtin/push.c | 36 ++++++++++++++++++++++++++++++++----
>  1 file changed, 32 insertions(+), 4 deletions(-)
>
> diff --git a/builtin/push.c b/builtin/push.c
> index 7045e4ef0c..d173c39283 100644
> --- a/builtin/push.c
> +++ b/builtin/push.c
> @@ -225,10 +225,38 @@ static void setup_push_current(struct remote *remote, struct branch *branch)
>  
>  static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular)
>  {
> -	if (triangular)
> -		setup_push_current(remote, branch);
> -	else
> -		setup_push_upstream(remote, branch, triangular, 1);
> +	if (triangular) {
> +		if (!branch)
> +			die(_(message_detached_head_die), remote->name);
> +		refspec_appendf(&rs, "%s:%s", branch->refname, branch->refname);
> +	} else {
> +		if (!branch)
> +			die(_(message_detached_head_die), remote->name);
> +		if (!branch->merge_nr || !branch->merge || !branch->remote_name)
> +			die(_("The current branch %s has no upstream branch.\n"
> +			    "To push the current branch and set the remote as upstream, use\n"
> +			    "\n"
> +			    "    git push --set-upstream %s %s\n"),
> +			    branch->name,
> +			    remote->name,
> +			    branch->name);
> +		if (branch->merge_nr != 1)
> +			die(_("The current branch %s has multiple upstream branches, "
> +			    "refusing to push."), branch->name);
> +		if (triangular)
> +			die(_("You are pushing to remote '%s', which is not the upstream of\n"
> +			      "your current branch '%s', without telling me what to push\n"
> +			      "to update which remote branch."),
> +			    remote->name, branch->name);
> +
> +		if (1) {
> +			/* Additional safety */
> +			if (strcmp(branch->refname, branch->merge[0]->src))
> +				die_push_simple(branch, remote);
> +		}
> +
> +		refspec_appendf(&rs, "%s:%s", branch->refname, branch->merge[0]->src);
> +	}
>  }
>  
>  static int is_workflow_triangular(struct remote *remote)
Previous: Felipe ContrerasNext: Felipe Contreras
Message 8 of 59 in “Unconvolutize push.default=simple”
  1. 0/6 Unconvolutize push.default=simpleFelipe Contreras, May 29, 2021
  2. 1/6 push: hedge code of default=simpleFelipe Contreras, May 29, 2021
  3. Junio C HamanoMay 31, 2021
  4. Felipe ContrerasMay 31, 2021
  5. 4/6 push: simplify setup_push_simple()Felipe Contreras, May 29, 2021
  6. Junio C HamanoMay 31, 2021
  7. 2/6 push: move code to setup_push_simple()Felipe Contreras, May 29, 2021
  8. Junio C HamanoMay 31, 2021
  9. Felipe ContrerasMay 31, 2021
  10. 3/6 push: reorganize setup_push_simple()Felipe Contreras, May 29, 2021
  11. Junio C HamanoMay 31, 2021
  12. 6/6 doc: push: explain default=simple correctlyFelipe Contreras, May 29, 2021
  13. Mathias KunterMay 30, 2021
  14. Felipe ContrerasMay 30, 2021
  15. Mathias KunterMay 31, 2021
  16. Felipe ContrerasMay 31, 2021
  17. Mathias KunterMay 31, 2021
  18. Felipe ContrerasMay 31, 2021
  19. Mathias KunterMay 31, 2021
  20. Felipe ContrerasMay 31, 2021
  21. Mathias KunterMay 31, 2021
  22. Junio C HamanoMay 31, 2021
  23. Felipe ContrerasMay 31, 2021
  24. Junio C HamanoJun 1, 2021
  25. Felipe ContrerasJun 1, 2021
  26. Philip OakleyJun 1, 2021
  27. Felipe ContrerasJun 1, 2021
  28. Philip OakleyJun 1, 2021
  29. Felipe ContrerasJun 1, 2021
  30. Junio C HamanoJun 1, 2021
  31. 5/6 push: remove unused code in setup_push_upstream()Felipe Contreras, May 29, 2021
  32. 00/15 push: revamp push.defaultFelipe Contreras, May 29, 2021
  33. 01/15 push: create new get_upstream_ref() helperFelipe Contreras, May 29, 2021
  34. 02/15 push: return immediately in trivial switch caseFelipe Contreras, May 29, 2021
  35. 03/15 push: reorder switch casesFelipe Contreras, May 29, 2021
  36. Junio C HamanoMay 31, 2021
  37. Felipe ContrerasMay 31, 2021
  38. 04/15 push: factor out null branch checkFelipe Contreras, May 29, 2021
  39. 05/15 push: only get the branch when neededFelipe Contreras, May 29, 2021
  40. Junio C HamanoMay 31, 2021
  41. Felipe ContrerasMay 31, 2021
  42. 06/15 push: make setup_push_* return the dstFelipe Contreras, May 29, 2021
  43. 10/15 push: remove redundant checkFelipe Contreras, May 29, 2021
  44. 08/15 push: get rid of all the setup_push_* functionsFelipe Contreras, May 29, 2021
  45. Junio C HamanoMay 31, 2021
  46. 07/15 push: trivial simplificationsFelipe Contreras, May 29, 2021
  47. 09/15 push: factor out the typical caseFelipe Contreras, May 29, 2021
  48. 11/15 push: fix Yoda conditionFelipe Contreras, May 29, 2021
  49. Junio C HamanoMay 31, 2021
  50. 14/15 push: don't get a full remote objectFelipe Contreras, May 29, 2021
  51. 13/15 push: only get triangular when neededFelipe Contreras, May 29, 2021
  52. Junio C HamanoMay 31, 2021
  53. 12/15 push: remove trivial functionFelipe Contreras, May 29, 2021
  54. 15/15 push: rename !triangular to same_remoteFelipe Contreras, May 29, 2021
  55. Junio C HamanoMay 31, 2021
  56. Philip OakleyMay 29, 2021
  57. Felipe ContrerasMay 30, 2021
  58. Ævar Arnfjörð BjarmasonMay 30, 2021
  59. Felipe ContrerasMay 30, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.