Re: [PATCH] git.c: fix help.autocorrect after 57ea712 breaks it
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 26, 2016, 19:02 UTC
- Message-ID
- <xmqqbn88cgfl.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <1453814801-1925-1-git-send-email-pclouds@gmail.com>
Nguyễn Thái Ngọc Duy <pclouds@gmail.com> writes:
Show 10 quoted lines
> diff --git a/git.c b/git.c
> index da278c3..cd733f7 100644
> --- a/git.c
> +++ b/git.c
> @@ -25,14 +25,15 @@ static const char *env_names[] = {
> GIT_PREFIX_ENVIRONMENT
> };
> static char *orig_env[4];
> -static int saved_env_before_alias;
> +static int saved_env_before_alias, saved;Even for a file-local static, this name is a bit too generic, isn't it? saved_env_count or something perhaps?
Show 43 quoted lines
> static void save_env_before_alias(void)
> {
> int i;
> - if (saved_env_before_alias)
> - return;
> + if (saved)
> + die("BUG: uneven pair of save_env/restore_env calls");
> saved_env_before_alias = 1;
> + saved = 1;
> orig_cwd = xgetcwd();
> for (i = 0; i < ARRAY_SIZE(env_names); i++) {
> orig_env[i] = getenv(env_names[i]);
> @@ -44,9 +45,13 @@ static void save_env_before_alias(void)
> static void restore_env(int external_alias)
> {
> int i;
> + if (saved != 1)
> + die("BUG: uneven pair of save_env/restore_env calls");
> if (!external_alias && orig_cwd && chdir(orig_cwd))
> die_errno("could not move to %s", orig_cwd);
> free(orig_cwd);
> + orig_cwd = NULL;
> + saved = 0;
> for (i = 0; i < ARRAY_SIZE(env_names); i++) {
> if (external_alias &&
> !strcmp(env_names[i], GIT_PREFIX_ENVIRONMENT))
> diff --git a/t/t1300-repo-config.sh b/t/t1300-repo-config.sh
> index 52678e7..3f95285 100755
> --- a/t/t1300-repo-config.sh
> +++ b/t/t1300-repo-config.sh
> @@ -1201,4 +1201,12 @@ test_expect_success POSIXPERM,PERL 'preserves existing permissions' '
> "die q(badrename) if ((stat(q(.git/config)))[2] & 07777) != 0600"
> '
>
> +test_expect_success 'autocorrect and save_env/restore_env' '
> + git config alias.ss status &&
> + git config help.autocorrect 1 &&
> + git sss --porcelain | grep actual >actual &&
> + echo "?? actual" >expected &&
> + test_cmp expected actual
> +'
> +
> test_done