git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/2] doc: update the documentation of pack-objects and repack

From
Junio C Hamano <gitster@pobox.com>
Date
Mar 3, 2020, 22:29 UTC
Message-ID
<xmqqa74x6pj3.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<20200303212302.znhumbjo7lywyhvh@doriath>
Damien Robert <damien.olivier.robert@gmail.com> writes:
> So do you suggest instead to remove all references to 'git-pack-objects'
> in 'git-repack'?
Not really.  If you are trying to remedy ...
> This is a high level overview, but the user who knows a bit about Git
> internals may wonder what exactly 'all' entails: non local objects, kept
> objects, promisor objects, unreachable objects?

... this kind of thing, I do not think that a solution that is the best for readers is not this:

> Knowing that the default options passed are:
> `--keep-true-parents`, `--all`, `--reflog`, `--indexed-objects`, `--exclude-promisor-objects`

that requires them to go down and read what --indexed-objects (for example) means in the documentation for "git pack-objects" command, and piece together what they mean when they are used together.

> answers this questions: it is essentially all objects except unreachable ones.

Yes, "all objects except unreachable ones", which you came up with, is a good description, I would think.

Previous: Damien RobertNext: Damien Robert
Message 7 of 15 in “Documentation of pack and repack”
  1. 0/2 Documentation of pack and repackDamien Robert, Feb 28, 2020
  2. 1/2 doc: update the documentation of pack-objects and repackDamien Robert, Feb 28, 2020
  3. Junio C HamanoMar 2, 2020
  4. Damien RobertMar 3, 2020
  5. Junio C HamanoMar 3, 2020
  6. Damien RobertMar 3, 2020
  7. Junio C HamanoMar 3, 2020
  8. 0/3 Documentation of pack and repackDamien Robert, Mar 12, 2020
  9. 1/3 pack-objects: change the name of add_objects_in_unpacked_packsDamien Robert, Mar 12, 2020
  10. 2/3 doc: update the documentation of pack-objects and repackDamien Robert, Mar 12, 2020
  11. 3/3 doc: add a short explanation for git-repack optionsDamien Robert, Mar 12, 2020
  12. Damien RobertMar 25, 2020
  13. Junio C HamanoMar 27, 2020
  14. 2/2 pack-objects: change the name of add_objects_in_unpacked_packsDamien Robert, Feb 28, 2020
  15. Damien RobertFeb 28, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.