Re: [PATCH 2/2] pack-objects: change the name of add_objects_in_unpacked_packs
- From
- Damien Robert <damien.olivier.robert@gmail.com>
- Date
- Feb 28, 2020, 16:01 UTC
- Message-ID
- <20200228160137.iqd3pxtsdameijs3@feanor>
- In-Reply-To
- <20200228154357.1710521-3-damien.olivier.robert+git@gmail.com>
From Damien Robert, Fri 28 Feb 2020 at 16:43:57 (+0100) :
> Now the function simply iterate through all packs (more precisely all > local packs not marked as .keep), and add all objects not already in the > object list.
By the way is there a corner case here?
When using `git repack --keep-unreachable --pack-kept-objects`, since `add_objects_in_unpacked_packs` does not add objects in *.keep packs, then unreachable objects there won't be added. Or am I missing something?