Re: [PATCH] statinfo.h: move DTYPE defines from dir.h
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 3, 2023, 02:30 UTC
- Message-ID
- <xmqq4jnp6zvv.fsf@gitster.g>
- In-Reply-To
- <CABPp-BHZ6a8VEuK=miMAcBG9RbUz+epuQ+d1xvwbRj_tsnYqcQ@mail.gmail.com>
Elijah Newren <newren@gmail.com> writes:
> There are two _different_ things named "struct dir_entry" in the codebase:
In the longer term, we should rename such a local type to avoid name clashes with the global one. But I of course am OK to leave it outside the topic to clean it up.
In any case, it is worth saying in the proposed log message why name-hash cannot use cache.h if we make it include dir.h; it is easy to do so (i.e. "it has its own 'dir_entry' that is used for other purpose").
Thanks.