Re: [PATCH v2] cache_tree_find(): remove redundant checks
David Kastrup <dak@gnu.org> writes:
Show 21 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
>
>> Michael Haggerty <mhagger@alum.mit.edu> writes:
>>
>>> while (*path) {
>>> - const char *slash;
>>> struct cache_tree_sub *sub;
>>> + const char *slash = strchr(path, '/');
>>>
>>> - slash = strchr(path, '/');
>>> if (!slash)
>>> slash = path + strlen(path);
>>
>> Isn't the above a strchrnul()?
>
> Yes. I realized that previously, but since it's a GNU extension rather
> than part of the C standards, I discarded that idea. Calling
>
> git grep strchrnul
>
> shows, however, that it _is_ used plentifully already.Yes, we have a fallback definition in compat-util, I think.
> Still worth thinking about whether there is no better name than slash
> for something that indicated the end of the current path name segment.
end_of_path_component? Sounds a bit too long ;-)