git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] cache_tree_find(): remove redundant checks

From
David Kastrup <dak@gnu.org>
Date
Mar 5, 2014, 04:38 UTC
Message-ID
<87eh2hi7jk.fsf@fencepost.gnu.org>
In-Reply-To
<xmqq8uspk72g.fsf@gitster.dls.corp.google.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 12 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes:
>
>>  	while (*path) {
>> -		const char *slash;
>>  		struct cache_tree_sub *sub;
>> +		const char *slash = strchr(path, '/');
>>  
>> -		slash = strchr(path, '/');
>>  		if (!slash)
>>  			slash = path + strlen(path);
>
> Isn't the above a strchrnul()?

Yes. I realized that previously, but since it's a GNU extension rather than part of the C standards, I discarded that idea. Calling

    git grep strchrnul
shows, however, that it _is_ used plentifully already.
That would, indeed, favor the current proposal but with strchnul.

Still worth thinking about whether there is no better name than slash for something that indicated the end of the current path name segment.

-- 
David Kastrup
Previous: Junio C HamanoNext: Junio C Hamano
Message 9 of 11 in “cache_tree_find(): remove redundant checks”
  1. cache_tree_find(): remove redundant checksMichael Haggerty, Mar 4, 2014
  2. David KastrupMar 4, 2014
  3. Michael HaggertyMar 4, 2014
  4. David KastrupMar 4, 2014
  5. Junio C HamanoMar 4, 2014
  6. Michael HaggertyMar 4, 2014
  7. Junio C HamanoMar 4, 2014
  8. Junio C HamanoMar 5, 2014
  9. David KastrupMar 5, 2014
  10. Junio C HamanoMar 5, 2014
  11. [microproject idea]Junio C Hamano, Mar 4, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.