Re: [PATCH 0/2] log_tree_diff: simplify
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 6, 2020, 21:52 UTC
- Message-ID
- <xmqq1rje4loz.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20200828110526.21145-1-sorganov@gmail.com>
Sergey Organov <sorganov@gmail.com> writes:
Show 9 quoted lines
> These patches are pure code quality improvements, -- they should introduce no > changes in behavior. > > Sergey Organov (2): > log_tree_diff: get rid of code duplication for first_parent_only > log_tree_diff: get rid of extra check for NULL > > log-tree.c | 21 +++++---------------- > 1 file changed, 5 insertions(+), 16 deletions(-)
It's been so long since I looked at the codepath that it wasn't immediately clear to me if we are doing the right thing around log->parent until I reread 91539833 (Log message printout cleanups, 2006-04-17) to rediscover what the field was for, but everything looks good to me.