Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Apr 9, 2010, 12:03 UTC
- Message-ID
- <vpqk4sgltoh.fsf@bauges.imag.fr>
- In-Reply-To
- <4BBF159A.1000206@drmicha.warpmail.net>
Michael J Gruber <git@drmicha.warpmail.net> writes:
> But I also have a functional question: Is "start_from" really the ref > *to* which the branch is reset? I hope reset does it right.
I don't know which is which, but if start_from is the destination of the ref, then it should be renamed. I don't think we want to have this
snprintf(msg, sizeof msg, "branch: Reset to %s",
^^
start_name);
^^^^^in the code.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/