threads / patch / 23389

patchbranch: say "Reset to" in reflog entries for 'git branch -f' operations

Subject: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations

## tl;dr

6 messages between Apr 9, 2010 and Apr 9, 2010. Diffs are folded; open one to read it.

replies: 5people: 4as markdown or json

Tay Ray Chuan· Apr 9, 2010, 07:45 UTC · lore

In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that 'git branch -f' is intended to be equivalent to 'git reset'. Since we usually say "reset to <commit>" in the git-reset Documentation and elsewhere, it would make sense to say "Reset to" here as well.

Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
---
  I happened to be perusing my branch's reflog when I spotted this.
 branch.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Show changes to branch.c +1 −2
diff --git a/branch.c b/branch.c
index 9e1f63e..2ab42aa 100644
--- a/branch.c
+++ b/branch.c
@@ -198,7 +198,7 @@ void create_branch(const char *head,
 		log_all_ref_updates = 1;

 	if (forcing)
-		snprintf(msg, sizeof msg, "branch: Reset from %s",
+		snprintf(msg, sizeof msg, "branch: Reset to %s",
 			 start_name);
 	else if (!dont_change_ref)
 		snprintf(msg, sizeof msg, "branch: Created from %s",
--
1.7.1.rc0.240.gba75f
Michael J Gruber· Apr 9, 2010, 11:55 UTC · re: Tay Ray Chuan · lore

Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations

Tay Ray Chuan venit, vidit, dixit 09.04.2010 15:45:
Show 5 quoted lines
> In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that
> 'git branch -f' is intended to be equivalent to 'git reset'. Since we
> usually say "reset to <commit>" in the git-reset Documentation and
> elsewhere, it would make sense to say "Reset to" here as well.
> 

I know the patch is not large, but one really has to read it after wondering: Huh? What is branch -f doing now before the patch? To me it sounded as if it didn't write to the reflog at all. So, how about

elsewhere, it would make sense to say "Reset to" here as well rather than "Rest from".

But I also have a functional question: Is "start_from" really the ref *to* which the branch is reset? I hope reset does it right.

Show 24 quoted lines
> Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
> ---
> 
>   I happened to be perusing my branch's reflog when I spotted this.
> 
>  branch.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/branch.c b/branch.c
> index 9e1f63e..2ab42aa 100644
> --- a/branch.c
> +++ b/branch.c
> @@ -198,7 +198,7 @@ void create_branch(const char *head,
>  		log_all_ref_updates = 1;
> 
>  	if (forcing)
> -		snprintf(msg, sizeof msg, "branch: Reset from %s",
> +		snprintf(msg, sizeof msg, "branch: Reset to %s",
>  			 start_name);
>  	else if (!dont_change_ref)
>  		snprintf(msg, sizeof msg, "branch: Created from %s",
> --
> 1.7.1.rc0.240.gba75f
> 
Matthieu Moy· Apr 9, 2010, 12:03 UTC · re: Michael J Gruber · lore

Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations

Michael J Gruber <git@drmicha.warpmail.net> writes:
> But I also have a functional question: Is "start_from" really the ref
> *to* which the branch is reset? I hope reset does it right.

I don't know which is which, but if start_from is the destination of the ref, then it should be renamed. I don't think we want to have this

		snprintf(msg, sizeof msg, "branch: Reset to %s",
                                                         ^^
 			 start_name);
                         ^^^^^
in the code.
-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
Johannes Sixt· Apr 9, 2010, 12:20 UTC · re: Matthieu Moy · lore

Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations

Am 4/9/2010 14:03, schrieb Matthieu Moy:
Show 14 quoted lines
> Michael J Gruber <git@drmicha.warpmail.net> writes:
> 
>> But I also have a functional question: Is "start_from" really the ref
>> *to* which the branch is reset? I hope reset does it right.
> 
> I don't know which is which, but if start_from is the destination of
> the ref, then it should be renamed. I don't think we want to have this
> 
> 		snprintf(msg, sizeof msg, "branch: Reset to %s",
>                                                          ^^
>  			 start_name);
>                          ^^^^^
> 
> in the code.
I think the patch is right.
The "start" part refers to where the branch forks off of existing history.

In the case were an existing branch is pointed to a new commit, the "Reset to" is indeed correct. IIUC, the "start_name" is what was given on the command line as fork point (or HEAD if not given). For example, after

   git branch -f thebranch master~23
the reflog of 'thebranch' would now read as "Reset to master~23".
-- Hannes
Tay Ray Chuan· Apr 9, 2010, 12:18 UTC · re: Michael J Gruber · lore

Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations

Hi,

On Fri, Apr 9, 2010 at 7:55 PM, Michael J Gruber <git@drmicha.warpmail.net> wrote:

Show 6 quoted lines
> I know the patch is not large, but one really has to read it after
> wondering: Huh? What is branch -f doing now before the patch? To me it
> sounded as if it didn't write to the reflog at all. So, how about
>
> elsewhere, it would make sense to say "Reset to" here as well rather
> than "Rest from".
Sounds good.
> But I also have a functional question: Is "start_from" really the ref
> *to* which the branch is reset? I hope reset does it right.
(I think you mean "start_name" instead of "start_from".)

Well, "start_name" determines where the branch/ref points to. I don't think any branch can "start", except that it can diverge.

But that's outside the scope of this patch.
-- 
Cheers,
Ray Chuan
Tay Ray Chuan· Apr 9, 2010, 12:38 UTC · re: Tay Ray Chuan · lore

[PATCH v2] branch: say "Reset to" in reflog entries for 'git branch -f' operations

In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that 'git branch -f' is intended to be equivalent to 'git reset'. Since we usually say "reset to <commit>" in the git-reset Documentation and elsewhere, it would make sense to say "Reset to" here as well, instead of "Reset from" previously.

Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
---
Changed from v1:
 - Mention old reflog message in patch message, as suggested by
   Michael J Gruber.
 branch.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Show changes to branch.c +1 −2
diff --git a/branch.c b/branch.c
index 9e1f63e..2ab42aa 100644
--- a/branch.c
+++ b/branch.c
@@ -198,7 +198,7 @@ void create_branch(const char *head,
 		log_all_ref_updates = 1;

 	if (forcing)
-		snprintf(msg, sizeof msg, "branch: Reset from %s",
+		snprintf(msg, sizeof msg, "branch: Reset to %s",
 			 start_name);
 	else if (!dont_change_ref)
 		snprintf(msg, sizeof msg, "branch: Created from %s",
--
1.7.1.rc0.240.gba75f

← back to recent threads