Re: [PATCH/WIP v3 2/4] for-each-ref: introduce new structures for better organisation
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- May 28, 2015, 20:41 UTC
- Message-ID
- <vpq8uc8l9k0.fsf@anie.imag.fr>
- In-Reply-To
- <55677C7F.6080400@gmail.com>
Karthik Nayak <karthik.188@gmail.com> writes:
Show 13 quoted lines
> On 05/29/2015 01:56 AM, Matthieu Moy wrote: >> Karthik Nayak <karthik.188@gmail.com> writes: >> >>> Rename 'refinfo' to 'ref_array_item' and intoduce 'ref_filter_cbdata' >> >> The fact that you need to use "and" to describe your changes is a hint >> that you can split better. >> > > But the patch alone wouldn't make much sense here, as the whole idea > is the introduction of the new structures and renaming 'refinfo' to > ref_array_item' was more of a byproduct to go along with the new > structures introduced.
The point of separating them is that the rename implies a relatively long patch (you have 17 occurences of 'refinfo' in the deletion part of your patch), but it is straightforward to review (apply, run "git diff --color-words" and press space a few times). But it is no longer so simple once you mix it with anything else.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/