Re: [PATCH v3] gitweb: standarize HTTP status codes
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Jun 19, 2008, 22:37 UTC
- Message-ID
- <m3hcbpm4pe.fsf@localhost.localdomain>
- In-Reply-To
- <1213907110-5080-1-git-send-email-LeWiemann@gmail.com>
Lea Wiemann <lewiemann@gmail.com> writes:
> Changes since v2: die_error now adds the reason strings defined by RFC > 2616 to the HTTP status code; incorporated Jakub's other suggestions. > Diff to v2 follows.
This address both of my concerns: first, that for someone examining Mechanize-based gitweb test number like 403, or 500 would be magical number without explanation (reason phrase) other than 'Error'.
Second, that for casual / accidental gitweb developer who has to add or modify a bit of code with die_error(...) wouldn't know which of "magic number" to use, if the case didn't fail into described situation. Now it is enough to example die_error(...) in addition to similar code...
> I didn't use the HTTP_NOT_FOUND etc. suggestion because I found it too > verbose and obtrusive.
I can agree with that.
> Just a friendly reminder, please remember that discussing fairly > trivial changes in-depth might be not a good use of all participants' > time [...]
Well, this was what I though was patch revies... :-/
> Anyways, I hope everyone is happy with this version of the patch.
FWIW:
Acked-by: Jakub Narebski <jnareb@gmail.com>
-- Jakub Narebski Poland ShadeHawk on #git