Re: [PATCH v7 0/5] config: introduce discovery.bare and protected config
- From
Glen Choo <chooglen@google.com>
- Date
- Jul 8, 2022, 20:35 UTC
- Message-ID
- <kl6l1quv737u.fsf@chooglen-macbookpro.roam.corp.google.com>
- In-Reply-To
- <xmqqtu7swgxd.fsf@gitster.g>
Junio C Hamano <gitster@pobox.com> writes:
Show 21 quoted lines
> "Glen Choo via GitGitGadget" <gitgitgadget@gmail.com> writes: > >> This version incorporates most of Taylor's comments and suggestions. Thanks >> especially for the wording suggestions, I struggled with those a lot :) >> >> (I believe) I've responded upthread with my intention for each comment. The >> only differences between that and the actual changes are: >> >> * In Documentation/git-config.txt, I dropped a suggestion to mention that >> "git config --local" is identical to the default behavior when writing >> options because I found it too hard to fit in. >> >> * In Documentation/config/discovery.txt, I took Taylor's suggestion, but >> didn't mention "discovery" for the same reasons. >> >> * I decided to leave out the protected config lookup functions. I made some >> POC patches at: > > These patches overall looked ok. I am not very happy to see the > proliferation of namespaces like safe.* and discovery.* that would > not likely to get the second variable, though.
Fair. I think `discovery.bare` is similar enough to `safe.directory` that it could belong in the safe.* namespace if we find a good name for it.
We rejected "safe.bareRepository" earlier because of the insinuation that bare repos are unsafe. Maybe:
- safe.bareDiscovery - safe.bareRepositoryDiscovery - safe.unspecifiedBareRepository - safe.discoveredBareRepository
"safe.unspecifiedBareRepository" is sounding pretty good to me actually.. Any thoughts?