git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/2] Allow http authentication via prompt for http push.

From
Amos King <amos.l.king@gmail.com>
Date
Mar 19, 2009, 23:22 UTC
Message-ID
<d8c371a80903191622i285211d1rebb57854c93babf3@mail.gmail.com>
In-Reply-To
<alpine.DEB.1.00.0903191755270.6357@intel-tinevez-2-302>

Sorry for the way I responded. It was not very appropriate of me. I do think that if you would take a little tact in your approach that you would keep developers trying to improve the code they are putting into git, and trying to contribute more often.

Amos

On Thu, Mar 19, 2009 at 11:59 AM, Johannes Schindelin <Johannes.Schindelin@gmx.de> wrote:

Show 47 quoted lines
> Hi,
>
> On Thu, 19 Mar 2009, Amos King wrote:
>
>> There is now a faux remote created in order to
>> be passed to http_init.
>>
>> Signed-off-by: Amos King <amos.l.king@gmail.com>
>> ---
>>  http-push.c |   11 ++++++++++-
>>  1 files changed, 10 insertions(+), 1 deletions(-)
>>
>> diff --git a/http-push.c b/http-push.c
>> index 9ac2664..468d5af 100644
>> --- a/http-push.c
>> +++ b/http-push.c
>> @@ -2195,7 +2195,16 @@ int main(int argc, char **argv)
>>
>>       memset(remote_dir_exists, -1, 256);
>>
>> -     http_init(NULL);
>> +     /*
>> +      * This is a faked remote so that http_init can
>> +      * get the correct data for builidng out athorization.
>> +      */
>
> You might want to pass this through aspell ;-)  Altough it will not
> suggest 'out ->our', I guess...
>
>> +     struct remote *remote;
>> +     remote = xcalloc(sizeof(*remote), 1);
>> +     ALLOC_GROW(remote->url, remote->url_nr + 1, remote->url_alloc);
>> +     remote->url[remote->url_nr++] = repo->url;
>> +
>> +     http_init(remote);
>
> Would 'fake' not be a more appropriate name than 'remote'?
>
> That would also make the patch 1/2 rather unnecessary (I also have to
> admit that I do not find 'repo' a better name, as we have a repository
> both locally and remotely, and this _is_ the remote repository, not the
> local one).
>
> Ciao,
> Dscho
>
>
-- 
Amos King
http://dirtyInformation.com
http://github.com/Adkron
--
Looking for something to do? Visit http://ImThere.com
Previous: Michael J Gruber
Message 7 of 7 in “Allow http authentication via prompt for http push.”
  1. 2/2 Allow http authentication via prompt for http push.Amos King, Mar 19, 2009
  2. Johannes SchindelinMar 19, 2009
  3. Amos KingMar 19, 2009
  4. Michael J GruberMar 20, 2009
  5. Amos KingMar 20, 2009
  6. Michael J GruberMar 20, 2009
  7. Amos KingMar 19, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.