Re: [PATCH 2/2] Allow http authentication via prompt for http push.
- From
Amos King <amos.l.king@gmail.com>
- Date
- Mar 19, 2009, 19:02 UTC
- Message-ID
- <d8c371a80903191202v6fb974f4t2321761d0cf21a70@mail.gmail.com>
- In-Reply-To
- <alpine.DEB.1.00.0903191755270.6357@intel-tinevez-2-302>
The issue with calling it remote is that it conflicts with the remote struct that is need for http_init, and is used in the rest of the code. So do you want me to make this small impact change or a larger and more broad sweeping change by changing the name of the other remote. I don't believe fake is a better name. I would hope that at some point the 'repo' struct would go away and we can make http_push work like all the other remote commands.
I also believe that 'out' is the correct word. It was not a typo, and I appreciate your suggestion of assuming that I can't spell just because I used a word that you didn't understand. I'm not building OUR authorization. I am building OUT authorization. Have you heard of building something out? Or even fleshing something out?
I appreciated your first responses to my other patch. Even if your tone was that of a person with low self-esteem who needs to pick unimportant details apart in order to stroke their own ego. Instead of responding in the same tone I thought I would respond nicely and get your feedback. Responses like your first one don't cause people to want to continue to contribute to the community.
I have a great idea. Why don't you try using the 'nice' tense in your next email instead of the high and mighty 'ass-hole' tense. Then I will gladly not use past tense in my commit messages, and others might respond more positively to your criticisms.
Fiek Dich, Amos
On Thu, Mar 19, 2009 at 11:59 AM, Johannes Schindelin <Johannes.Schindelin@gmx.de> wrote:
Show 47 quoted lines
> Hi, > > On Thu, 19 Mar 2009, Amos King wrote: > >> There is now a faux remote created in order to >> be passed to http_init. >> >> Signed-off-by: Amos King <amos.l.king@gmail.com> >> --- >> http-push.c | 11 ++++++++++- >> 1 files changed, 10 insertions(+), 1 deletions(-) >> >> diff --git a/http-push.c b/http-push.c >> index 9ac2664..468d5af 100644 >> --- a/http-push.c >> +++ b/http-push.c >> @@ -2195,7 +2195,16 @@ int main(int argc, char **argv) >> >> memset(remote_dir_exists, -1, 256); >> >> - http_init(NULL); >> + /* >> + * This is a faked remote so that http_init can >> + * get the correct data for builidng out athorization. >> + */ > > You might want to pass this through aspell ;-) Altough it will not > suggest 'out ->our', I guess... > >> + struct remote *remote; >> + remote = xcalloc(sizeof(*remote), 1); >> + ALLOC_GROW(remote->url, remote->url_nr + 1, remote->url_alloc); >> + remote->url[remote->url_nr++] = repo->url; >> + >> + http_init(remote); > > Would 'fake' not be a more appropriate name than 'remote'? > > That would also make the patch 1/2 rather unnecessary (I also have to > admit that I do not find 'repo' a better name, as we have a repository > both locally and remotely, and this _is_ the remote repository, not the > local one). > > Ciao, > Dscho > >
-- Amos King http://dirtyInformation.com http://github.com/Adkron -- Looking for something to do? Visit http://ImThere.com