git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/2] Allow http authentication via prompt for http push.

From
Michael J Gruber <git@drmicha.warpmail.net>
Date
Mar 20, 2009, 08:49 UTC
Message-ID
<49C35891.7010004@drmicha.warpmail.net>
In-Reply-To
<d8c371a80903191202v6fb974f4t2321761d0cf21a70@mail.gmail.com>
Amos King venit, vidit, dixit 19.03.2009 20:02:
Show 28 quoted lines
> The issue with calling it remote is that it conflicts with the remote
> struct that is need for http_init, and is used in the rest of the
> code.  So do you want me to make this small impact change or a larger
> and more broad sweeping change by changing the name of the other
> remote.  I don't believe fake is a better name.  I would hope that at
> some point the 'repo' struct would go away and we can make http_push
> work like all the other remote commands.
> 
> I also believe that 'out' is the correct word.  It was not a typo, and
> I appreciate your suggestion of assuming that I can't spell just
> because I used a word that you didn't understand.  I'm not building
> OUR authorization.  I am building OUT authorization.  Have you heard
> of building something out?  Or even fleshing something out?
> 
> I appreciated your first responses to my other patch.  Even if your
> tone was that of a person with low self-esteem who needs to pick
> unimportant details apart in order to stroke their own ego.  Instead
> of responding in the same tone I thought I would respond nicely and
> get your feedback.  Responses like your first one don't cause people
> to want to continue to contribute to the community.
> 
> I have a great idea.  Why don't you try using the 'nice' tense in your
> next email instead of the high and mighty 'ass-hole' tense.  Then I
> will gladly not use past tense in my commit messages, and others might
> respond more positively to your criticisms.
> 
> Fiek Dich,
> Amos

We don't want these obscenities on this list, whether in plain English or wrong German!

In fact, Dscho's criticism was not only constructive but nice, and not only by his standards.

You managed to have at least 2 (3 by our count) typos in one line, and Dscho pointed that out correctly and nicely.

Your second response (which I saw just before hitting send) doesn't show much new insight regarding the latter two points. I'll consider the first one dealt with by it.

Michael
Show 52 quoted lines
> On Thu, Mar 19, 2009 at 11:59 AM, Johannes Schindelin
> <Johannes.Schindelin@gmx.de> wrote:
>> Hi,
>>
>> On Thu, 19 Mar 2009, Amos King wrote:
>>
>>> There is now a faux remote created in order to
>>> be passed to http_init.
>>>
>>> Signed-off-by: Amos King <amos.l.king@gmail.com>
>>> ---
>>>  http-push.c |   11 ++++++++++-
>>>  1 files changed, 10 insertions(+), 1 deletions(-)
>>>
>>> diff --git a/http-push.c b/http-push.c
>>> index 9ac2664..468d5af 100644
>>> --- a/http-push.c
>>> +++ b/http-push.c
>>> @@ -2195,7 +2195,16 @@ int main(int argc, char **argv)
>>>
>>>       memset(remote_dir_exists, -1, 256);
>>>
>>> -     http_init(NULL);
>>> +     /*
>>> +      * This is a faked remote so that http_init can
>>> +      * get the correct data for builidng out athorization.
>>> +      */
>>
>> You might want to pass this through aspell ;-)  Altough it will not
>> suggest 'out ->our', I guess...
>>
>>> +     struct remote *remote;
>>> +     remote = xcalloc(sizeof(*remote), 1);
>>> +     ALLOC_GROW(remote->url, remote->url_nr + 1, remote->url_alloc);
>>> +     remote->url[remote->url_nr++] = repo->url;
>>> +
>>> +     http_init(remote);
>>
>> Would 'fake' not be a more appropriate name than 'remote'?
>>
>> That would also make the patch 1/2 rather unnecessary (I also have to
>> admit that I do not find 'repo' a better name, as we have a repository
>> both locally and remotely, and this _is_ the remote repository, not the
>> local one).
>>
>> Ciao,
>> Dscho
>>
>>
> 
> 
> 
Previous: Amos KingNext: Amos King
Message 4 of 7 in “Allow http authentication via prompt for http push.”
  1. 2/2 Allow http authentication via prompt for http push.Amos King, Mar 19, 2009
  2. Johannes SchindelinMar 19, 2009
  3. Amos KingMar 19, 2009
  4. Michael J GruberMar 20, 2009
  5. Amos KingMar 20, 2009
  6. Michael J GruberMar 20, 2009
  7. Amos KingMar 19, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.