Re: [PATCH v2 0/12] run-command: remove run_command_v_*()
Am 30.10.22 um 12:40 schrieb René Scharfe:
Show 13 quoted lines
> Replace the convenience functions run_command_v_opt() et. al. and use
> struct child_process and run_command() directly instead, for an overall
> code reduction and a simpler and more flexible API that allows creating
> argument lists without magic numbers and reduced risk of memory leaks.
>
> Changes since v1:
> - Do the return value fix earlier; it was only an afterthought before.
> Keep the colon (no "while at it, ...").
> - Break out the xstrdup(), oid_to_hex_r() and C99 cleanups.
> - Convert tricky string arrays before strvecs because Ævar didn't like
> the opposite order.
> - Extend the example code in tmp-objdir.h so it still only requires
> "cmd".
Forgot one:
- Fix grammar error in run-command.h added by the series in a comment
that goes away at the end.
René