Re: [PATCH 0/8] run-command: remove run_command_v_*()
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Oct 29, 2022, 19:32 UTC
- Message-ID
- <Y11/2hyApN5NLruq@nand.local>
- In-Reply-To
- <7407e074-4bd8-b351-7fa4-baf59b41880c@web.de>
On Thu, Oct 27, 2022 at 06:30:36PM +0200, René Scharfe wrote:
Show 7 quoted lines
> Replace the convenience functions run_command_v_opt() et. al. and use > struct child_process and run_command() directly instead, for an overall > code reduction and a simpler and more flexible API that allows creating > argument lists without magic numbers and reduced risk of memory leaks. > > This is a broken-out and polished version of the original scratch at > https://lore.kernel.org/git/9d924a5d-5c72-fbe6-270c-a8f6c5fc5850@web.de/
Thanks, this round is looking pretty good to me. It sounds like there were a couple of small comments for which a reroll would be appreciated.
Assuming that that all looks good, I can queue the rerolled version. Thanks.
Thanks, Taylor