Re: [RFC] bisect: Introduce skip-when to automatically skip commits
- From
Olliver Schinagl <oliver@schinagl.nl>
- Date
- Apr 6, 2024, 10:06 UTC
- Message-ID
- <b194ba7c-454b-494f-bef2-e9eac7ca87f1@schinagl.nl>
- In-Reply-To
- <xmqqcyr3s3gj.fsf@gitster.g>
On 06-04-2024 03:08, Junio C Hamano wrote:
Show 18 quoted lines
> Olliver Schinagl <oliver@schinagl.nl> writes: > >> Hey all, >> >> I've also got my work on a branch in my repo, if that helps to look at >> things, https://gitlab.com/olliver/git/-/tree/skip_bisect >> >> Also included is a script to be used as an example. I opted to use >> `git show`, which is nice because it works both on commits, but also >> on notes. >> >> Anyway, any thoughts on the bellow before I send the full series? >> >> Olliver > > I would not write get_skip_when() before studying the same file to > see if there already is a helper to read the whole file used in the > vicinity (like strbuf_read_file(), perhaps).
Fair enough. I'm a little worried about optimization vs readability. I think it makes it mre clear what the code does in its current form; but I'll investigate. Bisecting shouldn't be a computational often happening thing, so I'm not to worried about performance. But I'm not too familiar with the git code base, so I don't know either :p
Show 6 quoted lines
> > I do not have enough concentration to follow changes to > bisect_auto_next() is reasonable. Especially I do not know why > "bisect-skip_when" wants to exist and what it is trying to do, > besides the fact that its name looks horrible ;-). >
naming things, sure. I can look into this absolutly :)
But in short, bisect_auto_next was returning just after checkout It seemed. So after checkout, running the script seemed sensible. But I look at it as a normal git user. So you checkout, test your commit, skip to the next one if applicable.
I'll think of your two comments, and see if I can address them as you regain your concentration :p
But seeing that these are your main concerns, I'm more confident I'm not completly on the wrong path here.
Olliver