Re: [RFC] bisect: Introduce skip-when to automatically skip commits
- From
Olliver Schinagl <oliver@schinagl.nl>
- Date
- Apr 6, 2024, 10:22 UTC
- Message-ID
- <30eccdbc-f0c4-4b8f-b735-cf5613912a9f@schinagl.nl>
- In-Reply-To
- <xmqqcyr3s3gj.fsf@gitster.g>
On 06-04-2024 03:08, Junio C Hamano wrote:
Show 18 quoted lines
> Olliver Schinagl <oliver@schinagl.nl> writes: > >> Hey all, >> >> I've also got my work on a branch in my repo, if that helps to look at >> things, https://gitlab.com/olliver/git/-/tree/skip_bisect >> >> Also included is a script to be used as an example. I opted to use >> `git show`, which is nice because it works both on commits, but also >> on notes. >> >> Anyway, any thoughts on the bellow before I send the full series? >> >> Olliver > > I would not write get_skip_when() before studying the same file to > see if there already is a helper to read the whole file used in the > vicinity (like strbuf_read_file(), perhaps).
So I just remembered, when I started this journey, I wanted to squeeze it all into `get_terms()` and make it part of the terms struct, as that was passed around everywhere. I figured, I can rename it into being something more generic. But I realized that skip_when doesn't actually need to be passed around at all (which we can see in the current implementation). With get_terms() in my mind, I just what that function did.
I saw strbuf_read_file() but I didn't quite understand what it was doing, it was a bit cryptic at first. Now that you mention it however, I see the error of my ways, and that strbuf_read_file() might be good enough and do exactly what get_skip_when does.
So thank you for that hint :)
Olliver
Show 6 quoted lines
> > I do not have enough concentration to follow changes to > bisect_auto_next() is reasonable. Especially I do not know why > "bisect-skip_when" wants to exist and what it is trying to do, > besides the fact that its name looks horrible ;-). >