[PATCH v5 1/8] reset: rename is_missing to !is_in_reset_tree
- From
Victoria Dye via GitGitGadget <gitgitgadget@gmail.com>
- Date
- Oct 27, 2021, 14:39 UTC
- Message-ID
- <ad7013a31aa5688747c1606d8c38aa96365c3711.1635345563.git.gitgitgadget@gmail.com>
- In-Reply-To
- <pull.1048.v5.git.1635345563.gitgitgadget@gmail.com>
From: Victoria Dye <vdye@github.com>
Rename and invert value of `is_missing` to `is_in_reset_tree` to make the variable more descriptive of what it represents.
Signed-off-by: Victoria Dye <vdye@github.com> --- builtin/reset.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/builtin/reset.c b/builtin/reset.c index 51c9e2f43ff..d3695ce43c4 100644 --- a/builtin/reset.c +++ b/builtin/reset.c @@ -131,10 +131,10 @@ static void update_index_from_diff(struct diff_queue_struct *q, for (i = 0; i < q->nr; i++) { struct diff_filespec *one = q->queue[i]->one; - int is_missing = !(one->mode && !is_null_oid(&one->oid)); + int is_in_reset_tree = one->mode && !is_null_oid(&one->oid); struct cache_entry *ce; - if (is_missing && !intent_to_add) { + if (!is_in_reset_tree && !intent_to_add) { remove_file_from_cache(one->path); continue; } @@ -144,7 +144,7 @@ static void update_index_from_diff(struct diff_queue_struct *q, if (!ce) die(_("make_cache_entry failed for path '%s'"), one->path); - if (is_missing) { + if (!is_in_reset_tree) { ce->ce_flags |= CE_INTENT_TO_ADD; set_object_name_for_intent_to_add_entry(ce); }
-- gitgitgadget