Re: [PATCH 6/6] packfile: rename `packfile_store_get_all_packs()`
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Oct 8, 2025, 20:48 UTC
- Message-ID
- <aObOFciwYsvTWT0e@nand.local>
- In-Reply-To
- <20251007-pks-packfiles-convert-get-all-v1-6-428227657a89@pks.im>
On Tue, Oct 07, 2025 at 02:41:12PM +0200, Patrick Steinhardt wrote:
Show 6 quoted lines
> --- > builtin/fast-import.c | 4 ++-- > builtin/pack-objects.c | 4 ++-- > packfile.c | 2 +- > packfile.h | 4 ++-- > 4 files changed, 7 insertions(+), 7 deletions(-)
Hmm. I wonder if we should perform this step at a later date. My fear is that another topic in fight might introduce a new use of the "get_packs" assuming the old semantics.
Merging this topic and that hypothetical one together wouldn't produce a textual conflict, but it could introduce bugs where the hypothetical new code expects the old behavior.
Perhaps I'm overthinking this, but figured I'd write down the concern nonetheless.
Thanks, Taylor