Re: [PATCH] t9101: Refactor test_expect_success format
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Oct 31, 2024, 20:15 UTC
- Message-ID
- <ZyPlYkwsFrxH+JwE@nand.local>
- In-Reply-To
- <20241031094554.68916-1-kuforiji98@gmail.com>
On Thu, Oct 31, 2024 at 10:45:53AM +0100, Seyi Kuforiji wrote:
Show 7 quoted lines
> The current script uses an outdated formatting style for > test_expect_success blocks, where each argument is separated by a > backslash and newline. This style can lead to readability issues and > makes it harder to maintain the script. > > The modern style consolidates > the multi-line command arguments into a single quoted block, which
Strange line wrapping?
Show 7 quoted lines
> improves readability, maintainability, and aligns the code with current > coding standards. > > Signed-off-by: Seyi Kuforiji <kuforiji98@gmail.com> > --- > t/t9101-git-svn-props.sh | 48 ++++++++++++++++++++++------------------ > 1 file changed, 26 insertions(+), 22 deletions(-)
This does not apply cleanly on 'master', so I assume that you wanted it based on sk/t9101-cleanup. That's fine, but please let me know in the future in case it's every less obvious :-).
The changes themselves all look quite sensible, though.
Thanks, Taylor