Re: [PATCH 03/10] reftable/reader: rename `reftable_new_reader()`
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Aug 23, 2024, 05:22 UTC
- Message-ID
- <Zsgcr6MkBbXSQlBA@tanuki>
- In-Reply-To
- <xmqqbk1kqsr6.fsf@gitster.g>
On Thu, Aug 22, 2024 at 12:09:33PM -0700, Junio C Hamano wrote:
Show 16 quoted lines
> Justin Tobler <jltobler@gmail.com> writes: > > > On 24/08/19 05:39PM, Patrick Steinhardt wrote: > >> Rename the `reftable_new_reader()` function to `reftable_reader_new()` > >> to match our coding guidelines. > >> > >> Signed-off-by: Patrick Steinhardt <ps@pks.im> > >> --- > > [snip] > >> -int init_reader(struct reftable_reader *r, struct reftable_block_source *source, > >> +int reader_init(struct reftable_reader *r, struct reftable_block_source *source, > >> const char *name); > > > > Here we also rename `init_reader()` to `reader_init()`, but do not > > update its call sites resulting in build errors. Since we remove this in > > the next patch anyway, let's drop this change.
Well spotted! I originally wanted to fix that function's name, too. But then I realized it's not even needed in the first place.
Show 5 quoted lines
> True. The actual definition of the function is also left > unmodified. Let me locally edit the hunk out. As you pointed out, > the next step does mention the "new" name in order to remove it, so > there needs a cascading adjustment there, but the fallout is fairly > small (see the attached range-diff).
Thanks. The range diff looks as expected to me.
Patrick