Re: [PATCH 03/10] reftable/reader: rename `reftable_new_reader()`
- From
Justin Tobler <jltobler@gmail.com>
- Date
- Aug 22, 2024, 18:51 UTC
- Message-ID
- <7qfrzzhsplzmmjdygglfyum7d6qroiggeqonqptkzltgtcrdw5@wlukk42x6thn>
- In-Reply-To
- <e658b372f046616779cf49c6c9346a49c2ce1485.1724080006.git.ps@pks.im>
On 24/08/19 05:39PM, Patrick Steinhardt wrote:
Show 5 quoted lines
> Rename the `reftable_new_reader()` function to `reftable_reader_new()` > to match our coding guidelines. > > Signed-off-by: Patrick Steinhardt <ps@pks.im> > ---
[snip]
> -int init_reader(struct reftable_reader *r, struct reftable_block_source *source, > +int reader_init(struct reftable_reader *r, struct reftable_block_source *source, > const char *name);
Here we also rename `init_reader()` to `reader_init()`, but do not update its call sites resulting in build errors. Since we remove this in the next patch anyway, let's drop this change.
-Justin