Re: [PATCH 07/16] reftable/block: rename `block_reader` to `reftable_block`
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Apr 7, 2025, 12:30 UTC
- Message-ID
- <Z_PFfNwJVfVIuTPO@pks.im>
- In-Reply-To
- <y47rmb3ahghwvhdukfj27fihddmg57rqpfcqmaylfejqjjxvrr@luc7xuu5qiza>
On Wed, Apr 02, 2025 at 03:39:57PM -0500, Justin Tobler wrote:
Show 35 quoted lines
> On 25/03/31 10:41AM, Patrick Steinhardt wrote:
> > diff --git a/reftable/block.c b/reftable/block.c
> > index ad162ecdbf6..d188665388d 100644
> > --- a/reftable/block.c
> > +++ b/reftable/block.c
> > @@ -222,10 +222,10 @@ static int read_block(struct reftable_block_source *source,
> > return block_source_read_data(source, dest, off, sz);
> > }
> >
> > -int block_reader_init(struct block_reader *br,
> > - struct reftable_block_source *source,
> > - uint32_t offset, uint32_t header_size,
> > - uint32_t table_block_size, uint32_t hash_size)
> > +int reftable_block_init(struct reftable_block *block,
> > + struct reftable_block_source *source,
> > + uint32_t offset, uint32_t header_size,
> > + uint32_t table_block_size, uint32_t hash_size)
> > {
> > uint32_t guess_block_size = table_block_size ?
> > table_block_size : DEFAULT_BLOCK_SIZE;
> > @@ -236,19 +236,19 @@ int block_reader_init(struct block_reader *br,
> > uint8_t block_type;
> > int err;
> >
> > - err = read_block(source, &br->block, offset, guess_block_size);
> > + err = read_block(source, &block->block, offset, guess_block_size);
> > if (err < 0)
> > goto done;
> >
> > - block_type = br->block.data[header_size];
> > + block_type = block->block.data[header_size];
>
> Ah, in the previous patch I suggested renaming the `block` field to
> `data`, but I guess that would lead to `block->data.data` here and would
> also be a bit funny. It's probably fine to just leave it as-is then.Fair, but I think if we rename this to `block_data` then it's fine and helps to clarify things a bit. I've done that now.
Patrick