Re: [PATCH v3 00/10] Split up "object-file.c"
On Tue, Apr 15, 2025 at 11:41:34PM -0700, Elijah Newren wrote:
Show 24 quoted lines
> On Tue, Apr 15, 2025 at 2:38 AM Patrick Steinhardt <ps@pks.im> wrote:
> > Changes in v3:
> > - Rename `mkdir_in_gitdir()` to `safe_create_dir_in_gitdir()` to match
> > naming of similar functions.
> > - Move `safe_create_leading_directories()` et al into "path.c" instead
> > of into "dir.c". This also requires us to start injecting a repo via
> > parameters as "path.c" doesn't have `the_repository` available
> > anymore.
> > - Drop the commit that moves `index_blob_stream()` and related
> > functions.
> > - Expand the reasoning why we want to have cached objects per object
> > store instead of globally.
> > - Drop `index_blob_stream()`, which is a trivial wrapper around
> > `index_blob_bulk_checkin()`.
> > - Link to v2: https://lore.kernel.org/r/20250411-pks-split-object-file-v2-0-2bea0c9033ae@pks.im
>
> v3 also addressed my feedback on v1 & v2.
>
> [...]
> > Range-diff versus v2:
>
> I read over the range-diff and the three new patches (1, 2, & 7); this
> round looks good to me. I particularly like the extended rationale in
> the commit message for what is now patch 9.
Thanks for your review!
Patrick