Re: [PATCH 10/10] unpack_loose_rest(): rewrite return handling for clarity
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Feb 28, 2025, 00:36 UTC
- Message-ID
- <Z8EFGnUmyAAJ6DUY@nand.local>
- In-Reply-To
- <20250225063421.GJ1293961@coredump.intra.peff.net>
On Tue, Feb 25, 2025 at 01:34:21AM -0500, Jeff King wrote:
> This should make the logic a bit easier to follow. It does mean > duplicating the buf cleanup for errors, but it's a single line.
At least to my eyes, I actually prefer the state after 9/10 and would probably be OK to see this patch get dropped. I wish I had a compelling reason *why* I felt that way, but I think it may too subjective.
I don't feel strongly about it either way, though.
Thanks, Taylor