Re: [PATCH v4 4/4] convert: add "status=delayed" to filter process protocol
- From
Lars Schneider <larsxschneider@gmail.com>
- Date
- May 22, 2017, 20:33 UTC
- Message-ID
- <E2C871B0-DCDF-40C5-A559-C396F3C8AA66@gmail.com>
- In-Reply-To
- <0e2eb0e4-6efd-349e-21be-ae1133a6047b@web.de>
Show 21 quoted lines
> On 22 May 2017, at 21:52, Torsten Bögershausen <tboegi@web.de> wrote: > > On 2017-05-22 15:50, Lars Schneider wrote: >> +After Git received the pathnames, it will request the corresponding >> +blobs again. These requests contain a pathname and an empty content >> +section. The filter is expected to respond with the smudged content >> +in the usual way as explained above. >> +------------------------ >> +packet: git> command=smudge >> +packet: git> pathname=path/testfile.dat >> +packet: git> 0000 >> +packet: git> 0000 # empty content! >> +packet: git< status=success >> +packet: git< 0000 >> +packet: git< SMUDGED_CONTENT >> +packet: git< 0000 >> +packet: git< 0000 >> +------------------------ > > The documentation mentions "0000" 2 times. > Is this a bug in the docu ? Or a feature which may need a comment ?
The first 0000 marks the end of the content and the second 0000 marks the end of an empty status list.
Explained in the existing protocol here: https://github.com/git/git/blob/10c78a162fa821ee85203165b805ff46be454091/Documentation/gitattributes.txt#L451-L457 https://github.com/git/git/blob/10c78a162fa821ee85203165b805ff46be454091/Documentation/gitattributes.txt#L464
For clarity I should probably change it to this:
... packet: git< status=success packet: git< 0000 packet: git< SMUDGED_CONTENT packet: git< 0000 packet: git< 0000 # empty list, keep "status=success" unchanged!
Thanks, Lars