git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] builtin/receive-pack: avoid generic function name hmac

From
Eric Sunshine <sunshine@sunshineco.com>
Date
May 5, 2020, 05:52 UTC
Message-ID
<CAPig+cRE60kw-PeF=Di7O9Kw1P1CctCX0drDzGX3diVQ2-Fu1Q@mail.gmail.com>
In-Reply-To
<20200505054630.5821-1-carenas@gmail.com>

On Tue, May 5, 2020 at 1:46 AM Carlo Marcelo Arenas Belón <carenas@gmail.com> wrote:

Show 8 quoted lines
> [...]
> While the conflict, posses the question of why are we even implementing our
> own RFC 2104 complaint HMAC while alternatives are readily available, the
> simplest solution is to make sure the name is not as generic so it would
> conflict with an equivalent one from the system (or linked libraries); so
> rename it again to hmac_hash to reflect it will use the git's defined hash
> function.
> ---
Missing sign-off.
Previous: Carlo Marcelo Arenas BelónNext: Junio C Hamano
Message 2 of 8 in “builtin/receive-pack: avoid generic function name hmac”
  1. builtin/receive-pack: avoid generic function name hmacCarlo Marcelo Arenas Belón, May 5, 2020
  2. Eric SunshineMay 5, 2020
  3. Junio C HamanoMay 5, 2020
  4. Carlo Marcelo Arenas BelónMay 5, 2020
  5. brian m. carlsonMay 5, 2020
  6. Carlo Marcelo Arenas BelónMay 5, 2020
  7. builtin/receive-pack: avoid generic function name hmac()Carlo Marcelo Arenas Belón, May 5, 2020
  8. brian m. carlsonMay 5, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.