Re: [PATCH v2] builtin/receive-pack: avoid generic function name hmac()
On 2020-05-05 at 09:53:26, Carlo Marcelo Arenas Belón wrote:
Show 21 quoted lines
> fabec2c5c3 (builtin/receive-pack: switch to use the_hash_algo, 2019-08-18)
> renames hmac_sha1 to hmac, as it was updated to use the hash function used
> by git (which won't be sha1 in the future).
>
> hmac() is provided by NetBSD >= 8 libc and therefore conflicts as shown by :
>
> builtin/receive-pack.c:421:13: error: conflicting types for 'hmac'
> static void hmac(unsigned char *out,
> ^~~~
> In file included from ./git-compat-util.h:172:0,
> from ./builtin.h:4,
> from builtin/receive-pack.c:1:
> /usr/include/stdlib.h:305:10: note: previous declaration of 'hmac' was here
> ssize_t hmac(const char *, const void *, size_t, const void *, size_t, void *,
> ^~~~
>
> Rename it again to hmac_hash to reflect it will use the git's defined hash
> function and avoid the conflict, while at it update a comment to better
> describe the HMAC function that was used.
>
> Signed-off-by: Carlo Marcelo Arenas Belón <carenas@gmail.com>
Looks good. Thanks again for the patch.
--
brian m. carlson: Houston, Texas, US
OpenPGP: https://keybase.io/bk2204